• Operand
  • # (b)ring mi - belles.

gram:build

> ./nixos/module/share.nix

Lenses
(coming soon!)


{ channel, name, domain }:
{ home-manager, pkgs, ... }:
let
# run = pkgs.writeScriptBin "${name}.nu" command;
in {
  # system.userActivationScripts."${name}.nu".text = command;
  # environment.systemPackages = packages;
  networking.firewall.allowedTCPPorts = [ 80 443 channel ];

  # services.static-web-server = {
  #   enable = false;
  #   # listen = "127.0.0.1:${toString channel}";
  #   root = "/share";
  #   configuration.general.directory-listing = true;
  #   configuration.general.port = toString channel;
  # };

  # services.seafile = {
  #   enable = false;
  #   adminEmail = "calli.youngblood@gmail.com";
  #   initialAdminPassword = "abc123";
  #   seafileSettings = {
  #     fileserver.port = channel;
  #     fileserver.host = domain;
  #   };
  # };

  # services.snapserver = {
  #   enable = false;
  #     # tcp.port = channel;
  #     # tcp.listenAddress = "127.0.0.1"
  #     # tcp.enable = true;
  #     # streams.<name>.type
  #     # streams.<name>.sampleFormat
  #     # streams.<name>.query
  #     # streams.<name>.location
  #     # streams.<name>.codec
  #     # streams
  #     # streamBuffer
  #     # sendToMuted
  #     # sampleFormat
  #     # port = channel;
  #     # openFirewall = true;
  #     # listenAddress
  #     http.port = channel;
  #     http.listenAddress = "127.0.0.1";
  #     http.enable = true;
  #     http.docRoot = "/root/share";
  #     streams = {};
  #     # codec
  #     # buffer
  # };

  # services.caddy = { enable = true;
  #   virtualHosts.${domain}.extraConfig = ''
  #   reverse_proxy 127.0.0.1:${toString channel}
  #   log {
  #     output file /var/lib/caddy/${name}.log {
  #       roll_size     200MiB
  #       roll_local_time
  #       roll_keep     1440
  #       roll_keep_for 1440d
  #     }
  #   }
  #   '';
  # };
}