• Operand
  • ./bin/ganged/upon.

gram: build

> ./nixos/cell/minimal/index.nix

Lenses
(coming soon!)


{ home-manager, nixos-hardware, nixpkgs, ... }@sources:
nixpkgs.lib.nixosSystem {
  specialArgs = sources;

  modules = [
    (import ../../module/login.nix {
      user = "calliope";
      command = ''nu -e "session hop"'';
    })

    "${nixos-hardware}/framework/13-inch/11th-gen-intel/default.nix"
    home-manager.nixosModules.default

    ../../mach/base.nix
    ../../home/base.nix
    ../../home/record.nix

    ../../module/console.nix
    ../../module/energy.nix
    ../../module/essence.nix
    ../../module/package.nix
    ../../module/process.nix
    ../../module/session.nix
    ../../module/shell.nix
    ../../module/signal.nix
    ../../module/upgrade.nix

  ];
}